Instalación simplificada de Oracle 11g en Oracle Linux 6 usando el RPM oracle-rdbms-server-11gR2-preinstall

Buenas, en esta ocasión, fue necesario realizar instalación de Oracle 11g en Oracle Linux 6.9….

 

Con el fin de no perder demasiado tiempo configurando los parámetros a nivel de sistema operativo, y además de ello en la instalación de paquetes necesarios para Oracle 11g, decidí hacer uso de un paquete RPM llamado oracle-rdbms-server-11gR2-preinstall.

Dicho paquete existe también para Oracle 12c. Por ahora, nos enfocaremos en Oracle 11g.

Empecemos…

Ejecutamos la orden siguiente…

[root@pad ~]# cd /etc/yum.repos.d

Una vez dentro… ejecutamos el wget para traer el archivo repo desde el sitio de Oracle.

[root@pad yum.repos.d]# wget http://yum.oracle.com/public-yum-ol6.repo
--2018-11-22 09:39:47--  http://yum.oracle.com/public-yum-ol6.repo
Resolviendo yum.oracle.com... 104.91.139.83
Connecting to yum.oracle.com|104.91.139.83|:80... conectado.
Petición HTTP enviada, esperando respuesta... 200 OK
Longitud: 12045 (12K) 
Saving to: `public-yum-ol6.repo'

100%[===========================================================>] 12.045      --.-K/s   in 0,003s  

2018-11-22 09:39:48 (4,14 MB/s) - `public-yum-ol6.repo' saved [12045/12045]

[root@pad yum.repos.d]#

Una vez tenemos el archivo descargado, procedemos a instalarlo con el usuario root o con un usuario que tenga la capacidad de realizar la instalación.

Ejecutamos entonces el comando yum para instalar el paquete y es aquí donde el sistema se encargará de configurar todos los prerrequisitos que necesita Oracle para poderse instalar…

[root@pad yum.repos.d]# yum install oracle-rdbms-server-11gR2-preinstall
Complementos cargados:refresh-packagekit, security, ulninfo
Configurando el proceso de instalación
ol6_UEK_latest                                                                | 1.2 kB     00:00     
ol6_UEK_latest/primary                                                                             |  39 MB     01:53     
ol6_UEK_latest                                                                                                    820/820
ol6_latest                                                                                         | 1.4 kB     00:00     
ol6_latest/primary                                                                                 | 7.1 MB     00:15     
ol6_latest                                                                                                    11302/11302
Resolviendo dependencias
--> Ejecutando prueba de transacción
---> Package oracle-rdbms-server-11gR2-preinstall.x86_64 0:1.0-15.el6 will be instalado
--> Procesando dependencias: gcc para el paquete: oracle-rdbms-server-11gR2-preinstall-1.0-15.el6.x86_64
--> Procesando dependencias: gcc-c++ para el paquete: oracle-rdbms-server-11gR2-preinstall-1.0-15.el6.x86_64
--> Procesando dependencias: compat-libcap1 para el paquete: oracle-rdbms-server-11gR2-preinstall-1.0-15.el6.x86_64
--> Procesando dependencias: ksh para el paquete: oracle-rdbms-server-11gR2-preinstall-1.0-15.el6.x86_64
--> Procesando dependencias: libaio-devel para el paquete: oracle-rdbms-server-11gR2-preinstall-1.0-15.el6.x86_64
--> Procesando dependencias: compat-libstdc++-33 para el paquete: oracle-rdbms-server-11gR2-preinstall-1.0-15.el6.x86_64
--> Procesando dependencias: libstdc++-devel para el paquete: oracle-rdbms-server-11gR2-preinstall-1.0-15.el6.x86_64
--> Ejecutando prueba de transacción
---> Package compat-libcap1.x86_64 0:1.10-1 will be instalado
---> Package compat-libstdc++-33.x86_64 0:3.2.3-69.el6 will be instalado
---> Package gcc.x86_64 0:4.4.7-23.0.1.el6 will be instalado
--> Procesando dependencias: libgomp = 4.4.7-23.0.1.el6 para el paquete: gcc-4.4.7-23.0.1.el6.x86_64
--> Procesando dependencias: cpp = 4.4.7-23.0.1.el6 para el paquete: gcc-4.4.7-23.0.1.el6.x86_64
--> Procesando dependencias: cloog-ppl >= 0.15 para el paquete: gcc-4.4.7-23.0.1.el6.x86_64
--> Procesando dependencias: libgcc >= 4.4.7-23.0.1.el6 para el paquete: gcc-4.4.7-23.0.1.el6.x86_64
---> Package gcc-c++.x86_64 0:4.4.7-23.0.1.el6 will be instalado
--> Procesando dependencias: libstdc++ = 4.4.7-23.0.1.el6 para el paquete: gcc-c++-4.4.7-23.0.1.el6.x86_64
--> Procesando dependencias: libmpfr.so.1()(64bit) para el paquete: gcc-c++-4.4.7-23.0.1.el6.x86_64
---> Package ksh.x86_64 0:20120801-37.el6_9 will be instalado
---> Package libaio-devel.x86_64 0:0.3.107-10.el6 will be instalado
---> Package libstdc++-devel.x86_64 0:4.4.7-23.0.1.el6 will be instalado
--> Ejecutando prueba de transacción
---> Package cloog-ppl.x86_64 0:0.15.7-1.2.el6 will be instalado
--> Procesando dependencias: libppl_c.so.2()(64bit) para el paquete: cloog-ppl-0.15.7-1.2.el6.x86_64
--> Procesando dependencias: libppl.so.7()(64bit) para el paquete: cloog-ppl-0.15.7-1.2.el6.x86_64
---> Package cpp.x86_64 0:4.4.7-23.0.1.el6 will be instalado
---> Package libgcc.x86_64 0:4.4.7-18.el6 will be actualizado
---> Package libgcc.x86_64 0:4.4.7-23.0.1.el6 will be an update
---> Package libgomp.x86_64 0:4.4.7-18.el6 will be actualizado
---> Package libgomp.x86_64 0:4.4.7-23.0.1.el6 will be an update
---> Package libstdc++.x86_64 0:4.4.7-18.el6 will be actualizado
---> Package libstdc++.x86_64 0:4.4.7-23.0.1.el6 will be an update
---> Package mpfr.x86_64 0:2.4.1-6.el6 will be instalado
--> Ejecutando prueba de transacción
---> Package ppl.x86_64 0:0.10.2-11.el6 will be instalado
--> Resolución de dependencias finalizada

Dependencias resueltas

==========================================================================================================================
 Paquete                                        Arquitectura     Versión                       Repositorio          Tamaño
==========================================================================================================================
Instalando:
 oracle-rdbms-server-11gR2-preinstall           x86_64           1.0-15.el6                    ol6_latest            21 k
Instalando para las dependencias:
 cloog-ppl                                      x86_64           0.15.7-1.2.el6                ol6_latest            93 k
 compat-libcap1                                 x86_64           1.10-1                        ol6_latest            17 k
 compat-libstdc++-33                            x86_64           3.2.3-69.el6                  ol6_latest           183 k
 cpp                                            x86_64           4.4.7-23.0.1.el6              ol6_latest           3.7 M
 gcc                                            x86_64           4.4.7-23.0.1.el6              ol6_latest            10 M
 gcc-c++                                        x86_64           4.4.7-23.0.1.el6              ol6_latest           4.7 M
 ksh                                            x86_64           20120801-37.el6_9             ol6_latest           761 k
 libaio-devel                                   x86_64           0.3.107-10.el6                ol6_latest            13 k
 libstdc++-devel                                x86_64           4.4.7-23.0.1.el6              ol6_latest           1.6 M
 mpfr                                           x86_64           2.4.1-6.el6                   ol6_latest           156 k
 ppl                                            x86_64           0.10.2-11.el6                 ol6_latest           1.3 M
Actualizando para las dependencias:
 libgcc                                         x86_64           4.4.7-23.0.1.el6              ol6_latest           104 k
 libgomp                                        x86_64           4.4.7-23.0.1.el6              ol6_latest           135 k
 libstdc++                                      x86_64           4.4.7-23.0.1.el6              ol6_latest           295 k

Resumen de la transacción
==========================================================================================================================
Instalar      12 Paquete(s)
Actualizar       3 Paquete(s)

Tamaño total de la descarga: 23 M
Está de acuerdo [s/N]:

Muy bien, aquí entonces respondemos afirmativamente y seguirá adelante la instalación y adecuación de prerrequisitos.

Está de acuerdo [s/N]:s
Descargando paquetes:
(1/15): cloog-ppl-0.15.7-1.2.el6.x86_64.rpm                                                        |  93 kB     00:00     
(2/15): compat-libcap1-1.10-1.x86_64.rpm                                                           |  17 kB     00:00     
(3/15): compat-libstdc++-33-3.2.3-69.el6.x86_64.rpm                                                | 183 kB     00:01     
(4/15): cpp-4.4.7-23.0.1.el6.x86_64.rpm                                                            | 3.7 MB     00:33     
(5/15): gcc-4.4.7-23.0.1.el6.x86_64.rpm                                                             |  10 MB     01:29     
(6/15): gcc-c++-4.4.7-23.0.1.el6.x86_64.rpm                                                         | 4.7 MB     00:49     
(7/15): ksh-20120801-37.el6_9.x86_64.rpm                                                            | 761 kB     00:06     
(8/15): libaio-devel-0.3.107-10.el6.x86_64.rpm                                                      |  13 kB     00:00     
(9/15): libgcc-4.4.7-23.0.1.el6.x86_64.rpm                                                          | 104 kB     00:01     
(10/15): libgomp-4.4.7-23.0.1.el6.x86_64.rpm                                                        | 135 kB     00:01     
(11/15): libstdc++-4.4.7-23.0.1.el6.x86_64.rpm                                                      | 295 kB     00:03     
(12/15): libstdc++-devel-4.4.7-23.0.1.el6.x86_64.rpm                                                | 1.6 MB     00:17     
(13/15): mpfr-2.4.1-6.el6.x86_64.rpm                                                                | 156 kB     00:01     
(14/15): oracle-rdbms-server-11gR2-preinstall-1.0-15.el6.x86_64.rpm                                 |  21 kB     00:00     
(15/15): ppl-0.10.2-11.el6.x86_64.rpm                                                               | 1.3 MB     00:12     
---------------------------------------------------------------------------------------------------------------------------
Total                                                                                      106 kB/s |  23 MB     03:44     
Ejecutando el rpm_check_debug
Ejecutando prueba de transacción
La prueba de transacción ha sido exitosa
Ejecutando transacción
  Actualizando  : libgcc-4.4.7-23.0.1.el6.x86_64                                                                      1/18 
  Actualizando  : libstdc++-4.4.7-23.0.1.el6.x86_64                                                                   2/18 
  Instalando    : libstdc++-devel-4.4.7-23.0.1.el6.x86_64                                                             3/18 
  Instalando    : mpfr-2.4.1-6.el6.x86_64                                                                             4/18 
  Instalando    : cpp-4.4.7-23.0.1.el6.x86_64                                                                         5/18 
  Instalando    : ppl-0.10.2-11.el6.x86_64                                                                            6/18 
  Instalando    : cloog-ppl-0.15.7-1.2.el6.x86_64                                                                     7/18 
  Instalando    : compat-libstdc++-33-3.2.3-69.el6.x86_64                                                             8/18 
  Instalando    : ksh-20120801-37.el6_9.x86_64                                                                        9/18 
  Instalando    : libaio-devel-0.3.107-10.el6.x86_64                                                                 10/18 
  Actualizando  : libgomp-4.4.7-23.0.1.el6.x86_64                                                                    11/18 
  Instalando    : gcc-4.4.7-23.0.1.el6.x86_64                                                                        12/18 
  Instalando    : gcc-c++-4.4.7-23.0.1.el6.x86_64                                                                    13/18 
  Instalando    : compat-libcap1-1.10-1.x86_64                                                                       14/18 
  Instalando    : oracle-rdbms-server-11gR2-preinstall-1.0-15.el6.x86_64                                             15/18 
  Limpieza      : libstdc++-4.4.7-18.el6.x86_64                                                                      16/18 
  Limpieza      : libgcc-4.4.7-18.el6.x86_64                                                                         17/18 
  Limpieza      : libgomp-4.4.7-18.el6.x86_64                                                                        18/18 
  Verifying     : compat-libcap1-1.10-1.x86_64                                                                        1/18 
  Verifying     : libgomp-4.4.7-23.0.1.el6.x86_64                                                                     2/18 
  Verifying     : oracle-rdbms-server-11gR2-preinstall-1.0-15.el6.x86_64                                              3/18 
  Verifying     : cpp-4.4.7-23.0.1.el6.x86_64                                                                         4/18 
  Verifying     : libstdc++-devel-4.4.7-23.0.1.el6.x86_64                                                             5/18 
  Verifying     : libaio-devel-0.3.107-10.el6.x86_64                                                                  6/18 
  Verifying     : ksh-20120801-37.el6_9.x86_64                                                                        7/18 
  Verifying     : mpfr-2.4.1-6.el6.x86_64                                                                             8/18 
  Verifying     : libstdc++-4.4.7-23.0.1.el6.x86_64                                                                   9/18 
  Verifying     : compat-libstdc++-33-3.2.3-69.el6.x86_64                                                            10/18 
  Verifying     : gcc-c++-4.4.7-23.0.1.el6.x86_64                                                                    11/18 
  Verifying     : gcc-4.4.7-23.0.1.el6.x86_64                                                                        12/18 
  Verifying     : ppl-0.10.2-11.el6.x86_64                                                                           13/18 
  Verifying     : libgcc-4.4.7-23.0.1.el6.x86_64                                                                     14/18 
  Verifying     : cloog-ppl-0.15.7-1.2.el6.x86_64                                                                    15/18 
  Verifying     : libgomp-4.4.7-18.el6.x86_64                                                                        16/18 
  Verifying     : libgcc-4.4.7-18.el6.x86_64                                                                         17/18 
  Verifying     : libstdc++-4.4.7-18.el6.x86_64                                                                      18/18 

Instalado:
  oracle-rdbms-server-11gR2-preinstall.x86_64 0:1.0-15.el6                                                                 

Dependencia(s) instalada(s):
  cloog-ppl.x86_64 0:0.15.7-1.2.el6    compat-libcap1.x86_64 0:1.10-1          compat-libstdc++-33.x86_64 0:3.2.3-69.el6   
  cpp.x86_64 0:4.4.7-23.0.1.el6        gcc.x86_64 0:4.4.7-23.0.1.el6           gcc-c++.x86_64 0:4.4.7-23.0.1.el6           
  ksh.x86_64 0:20120801-37.el6_9       libaio-devel.x86_64 0:0.3.107-10.el6    libstdc++-devel.x86_64 0:4.4.7-23.0.1.el6   
  mpfr.x86_64 0:2.4.1-6.el6            ppl.x86_64 0:0.10.2-11.el6             

Dependencia(s) actualizada(s):
  libgcc.x86_64 0:4.4.7-23.0.1.el6       libgomp.x86_64 0:4.4.7-23.0.1.el6       libstdc++.x86_64 0:4.4.7-23.0.1.el6      

¡Listo!
[root@pad yum.repos.d]#

Perfecto, hemos adecuado nuestro servidor para llevar a cabo la instalación de Oracle 11g.

Esto es todo, nos resta realizar la instalación.

 

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *